Please login or register.

Experimental trezor firmware testing

DO NOT UPGRADE YOUR FIRMWARE IF YOU DON'T HAVE YOUR RECOVERY SEEDS

I worked on a trezor firmware which supports XMR awhile back but stopped development around August last year. I want to "complete" the firmware soon and then release the source to github when it's somewhat stable. I'm releasing the binary since I need help testing the current version.

While there are user interaction limitations, the firmware is fully functional and can be used to sync accounts as well as transfer XMR from active accounts. Only simplewallet is supported at the moment and from my testing, windows is fairly stable while linux needs some work [FIXED].

The firmware is compatible with BTC and does not remove any functionality available in the official firmware. The source is upstream compatible and can be merged to the official source (if they want to). XMR uses the same seed as BTC so you can restore your old seed anytime and regain your old account.

There are important points to note:

  • The viewkey is sent to the client. A bad client could potentially store these keys and see all incoming transactions to your account, privacy is then compromised.
  • The client has no access to the sendkey and can only request the device to generate key images or sign transactions. Your funds are safe.
  • It takes about 40ms to generate each key image. For large wallets, re-sync is going to take a while, so keep the wallet bin files.
  • [FIXED] The send confirmation prompt is incomplete. It will be fixed in subsequent versions.
  • [FIXED] There is no reconnect/retry implemented in simplewallet at the moment.
  • Max mix level is 9

V0925: trezor_xmr_test_firmware_0925

  • Updated to trezor source v1.4.0

V0313: trezor_xmr_test_firmware_0313_win64

V0313: trezor_xmr_test_firmware_0313_linux64

V0313: trezor_xmr_test_firmware_0313_osx64

  • Fixed Bus: 10 error

V0311

  • Added reconnect handler when trezor is unplugged while simplewallet is active
  • Added tx_seckey storage support to firmware
  • Added support for 'address' simplewallet command
  • Fixed support for entering passwords when trezor is initialized/recovered with password protection enabled

V0306

  • Added binaries for linux-64 and osx-64
  • Fixed usb transport bug in linux/osx
  • Updated source to master b96147030cf06b7adacafebff196bc23a4b19199
  • Added trezorctl to wipe, reset, recover the trezor
  • Added trezorctl option to recover the monero mnemonic from the trezor seed given a specific address index

V0303

  • Added send prompts when transferring xmr with multi destination support.
  • Fix: added error handler when mixin level is > 9
  • Fix: added error handler when sending to > 10 addresses in a single transaction.

V0301

  • Test release

Upgrade instructions:

  1. Disconnect the trezor from the USB cable.
  2. Press both buttons on the trezor then connect the USB cable.
  3. Run upload.bat. Wait until new firmware upload is completed.
  4. Verify firmware fingerprint (from fingerprint.txt)
  5. Disconnect then reconnect trezor to USB.
  6. Go to MyTrezor.com (using CHROME) and initialize your device. (You have the option to restore your SEED words if you want to keep using the trezor with your current BTC (etc.) account.
  7. Close CHROME. Otherwise, it will not release the trezor USB device and simplewallet will not find it.
  8. Run simplewallet.exe --hardware-wallet n (n can be any reasonable number eg. --hardware-wallet 0)

PIN Entering: https://github.com/trezor/python-trezor

47AYtJeNKJjYNZLj71nBW938mbFSFwq1x4qVcNhBmdfUjhaqiGN7wqpVjH419eLYPzHFeF3TgzY2fDivz5EyGBYUSbAXwed

Replies: 58
ferretinjapan posted 1 year ago Replies: 1 | Weight: 0 | Link [ - ]

I tried loading the firmware usng your instructions onto a completely new Trezor, loaded the firmware and initialised without a hitch. However, on running simplewallet, it returns the error that the library libdb_cxx-6.0.dll could not be found. I'm running a win7 64 bit machine.

Reply to: ferretinjapan
NoodleDoodle posted 1 year ago Replies: 1 | Weight: 0 | Link [ - ]

I've updated the archive with the missing dll's, hopefully this fixes the problem.

Reply to: NoodleDoodle ferretinjapan
ferretinjapan posted 1 year ago Replies: 1 | Weight: 0 | Link [ - ]

Thanks, that did the trick! It runs, but I have no idea how to input the pin properly when it is requested. How does that work on the command line?

Reply to: ferretinjapan NoodleDoodle ferretinjapan
NoodleDoodle edited 1 year ago Replies: 2 | Weight: 0 | Link [ - ]

Please use the numeric keypad to input the corresponding box.

Reply to: NoodleDoodle ferretinjapan NoodleDoodle ferretinjapan
ferretinjapan posted 1 year ago Weight: 0 | Link [ - ]

Ta. It looks pretty good so far. Wallet loads up after initialisation in chrome on mytrezor.com, loaded up with simplewallet no problem, made a watching wallet from the viewkey which is synched on the 9.1 version of simplewallet. Looks like the watchonly wallet see all the transactions it is supposed to. Sent a Monero to the Trezor address and recognised the transaction on the network. Once it unlocked I sent some of it back after confirming it on the Trezor. Recognised by the network no problem. So far so good! Fantastic work getting this up and going BTW, I thought we'd be waiting more than a year for something even close to a Monero hardware wallet.

pa edited 1 year ago Replies: 1 | Weight: 0 | Link [ - ]

Is this ready for testing on OS X?

NoodleDoodle posted 1 year ago Weight: 0 | Link [ - ]

Client and firmware updated to V0303

Reply to: pa
NoodleDoodle edited 1 year ago Weight: 0 | Link [ - ]

Not yet. Will set up a build env after I add the retry/reconnect functions.

ferretinjapan posted 1 year ago Replies: 1 | Weight: 0 | Link [ - ]

Did a little further testing today and tried restoring the 24 word deterministic seed generated on the Trezor via simplewallet, unfortunately simplewallet requires 25 words. :/ If I recall the 25th word is something like an error checking word or something. I'm guessing this is something that will need to be added to the todo list.

palexander edited 1 year ago Weight: 0 | Link [ - ]

When I try to run this after following the instructions, simplewallet asks for a password immediately. When I can't supply one (just press enter) or if I supply one, it faults out with the message "error: failed to initialized hardware wallet". This was performed on a brand new Trezor with no initialization until I started following the instructions. Does the Trezor need setup with bitcoin first via mytrezor.com?

ERROR C:/trezor/new2/bitmonero/src/simplewallet/simplewallet.cpp:2825

Also, all my Monero related files are on another drive. (other than C: if that makes any difference)

Edit: Nevermind, yeah, you have to follow through with setting up Trezor on mytrezor.com initially.

Reply to: ferretinjapan
NoodleDoodle edited 1 year ago Replies: 1 | Weight: 0 | Link [ - ]

The 24 word recovery seed is intended for the trezor hardware itself and not for simplewallet (et al.). Please follow the following instructions when you want to recover your "old" account using the 24 word seed -> https://doc.satoshilabs.com/trezor-user/recovery.html

Reply to: NoodleDoodle ferretinjapan
ferretinjapan posted 1 year ago Replies: 1 | Weight: 0 | Link [ - ]

Hmmm, I'm not sure I follow. restoring the Trezor with the 24 word seed is straightforward, but what would I do if I lost the Trezor, but still had the seed and wanted to just use simplewallet's wallet functionality without the Trezor? How do you load the 24 word seed with simplewallet so that you can recover your funds?

Reply to: ferretinjapan NoodleDoodle ferretinjapan
NoodleDoodle edited 1 year ago Replies: 1 | Weight: 0 | Link [ - ]

With BTC, you'll need another application like Electrum to recover your trezor accounts. The same process is applicable to XMR. I'll publish a tool to output a mnemonic for a specific account index or maybe even add it as a simplewallet command line option. Once the source is out, anybody can do this as well.