Please login or register.

Bitmonerod Node on RPi2 - Working

A BIG thanks to NoodleDoodle, smooth & saddam for helping me.

Kit Used


Manhattan 7-port USB 2.0 hub

Verbatim s256gb SSD

Download ubuntu for RPi2

Follow these instructions for getting UBUNTU on to your SSD or USB RaspiPress remember you're installing ubuntu not wheezy!

At this point I get the RPi2 to a point that I can disconnect the monitor, keyboard etc

I also MAC reserved the RPi2's IP Address via DHCP (On your router or DHCP server, so it has a consistent IP Address)

So a few tasks are required first

sudo apt-get update
sudo apt-get upgrade
sudo apt-get install openssh-server
sudo halt -p

This powers it off so you can disconnect monitor, keyboard etc and SSH in from where you would normally

power up and ssh on to your RPi2

ssh [email protected]


bubtu@ububtu:~$ passwd
Changing password for ubuntu.
(current) UNIX password:
Enter new UNIX password:
Retype new UNIX password:
passwd: password updated successfully
sudo apt-get install dphys-swapfile

I've left the swap settings as default

sudo apt-get install screen

Screen is great, you can disconnect from the session and know it's still running fine Ctrl+Alt+d

Thats the preparing of the RasPi2 with ubuntu complete

You now need to install all the dependencies that bitmonero requires

sudo apt-get install git vim libboost1.55-all-dev build-essential doxygen libevent-dev libunbound-dev miniupnpc liblmdb-dev cmake libdb++-dev
git clone bitmonero

then we compile - took just under 2 hours for me.

cd bitmonero
make -j2 release-arm7

The -j2 is to use the extra cores from your RPi2 - I've seen some bitcoin core instructions using -j4 for compiling

Once done you're ready to launch

cd build/release/bin
./bitmonerod --db-type berkeley

This took me about 36 hours to sync the blockchain

But it works a treat :-)

Syntax for starting bitmonero as a node

./bitmonerod --db-type=berkeley --rpc-bind-ip --rpc-bind-port 5012

Syntax for starting simmplewallet to your new remote node

./simplewallet --daemon-address 192.168.0.XX:5012 --wallet-file ./wallet.bin
Replies: 16
osensei edited 8 years ago Weight: -194 | Link [ - ]

Hi, I just wanted to share a tip that could be added to the tutorial.

I've noticed that the process irqbalance starts to eat a lot of memory as time passes by. This is due to a bug which is explained and fixed here, and is also reported in launchpad.

It can be solved by either building a newer irqbalance from source, or installing it from this PPA

jml390 edited 8 years ago Weight: -218 | Link [ - ]

post deleted, due to smooth's correction.

Dufkin posted 8 years ago Replies: 3 | Weight: -272 | Link [ - ]

Thank you for this precise tutorial. It worked very good so far for me. However, you are writing that it took you 32hours to sync, whereas my RasPi2 is syncing for almost 48 hours now and still tells me that it is 352 days behind (started with 397 behind or so). Any ideas?

Reply to: Dufkin
jml390 edited 8 years ago Replies: 1 | Weight: -218 | Link [ - ]

post deleted, due to smooth's correction.

Reply to: jml390 Dufkin
wedgy2k posted 8 years ago Weight: -204 | Link [ - ]

Hi jml390 - Apologies for the delay in response.

Yes it did take about 32 hours for me to sync. I have a 40Mbps internet connect, My RPI2 is built exactly as above using a Verbatim SSD for the OS and DATA partition for my RPI2. See in the previous answer I did crank up the --limit-rate-down 12288 --limit-rate-up 2048 --limit-rate 14336 to force it to download the blockchain quicker.

My Launch syntax looks like :-

./bitmonerod --db-type=berkeley --rpc-bind-ip --rpc-bind-port 5012 --limit-rate-down 12288 --limit-rate-up 2048 --limit-rate 14336

See my backup by SSH post so you can ensure you save the blockchain, if you have a disaster (This is for my MAC - I guess RoboCopy will work for Windows) you don't have t start again and have a copy of your berkeley folder. backup link

Reply to: Dufkin
Dufkin posted 8 years ago Replies: 1 | Weight: -254 | Link [ - ]

So I was patient enough to just let it snyc. It took finally 1 1/2 weeks to fully synchronize and I had to restart it twice due to error messages. Fortunately my SD-Card didn't crash. I used the SanDisk ultra microSDHC UHS-I 32GB Card.

Reply to: Dufkin Dufkin
saddam posted 8 years ago Replies: 1 | Weight: -243 | Link [ - ]

It was faster because of SSD, whereas the sd card is slow. If you use an external HD of any kind it will be much faster.

Reply to: saddam Dufkin Dufkin
saddam posted 8 years ago Weight: -243 | Link [ - ]

whoops i see this was already responded to, disregard :/

Reply to: Dufkin
wedgy2k edited 8 years ago Replies: 1 | Weight: -272 | Link [ - ]

Hi Dufkin, thats why I bit the bullet and purchased the SSD - If you see my other thread, I've been trying to do this since April, so I just wanted it to work and NoodleDoodle's latest commit done the trick. I did use the bandwidth switches to hurry it up a bit (but dependeds on who you share your internet connections with)

--limit-rate-down 12288 --limit-rate-up 2048 --limit-rate 14336

Reply to: wedgy2k Dufkin
Dufkin posted 8 years ago Weight: -272 | Link [ - ]

Haha, ok read your other thread and I see the problem now... Thanks for your reply :)

bigreddmachine posted 8 years ago Replies: 1 | Weight: -307 | Link [ + ]

Hey - is there a reason why you chose Ubuntu instead of Raspbian? I saw you made note of it, but I didn't see an explanation.

Reply to: bigreddmachine
saddam posted 8 years ago Weight: -307 | Link [ + ]

One reason is that its easier to get the newest Boost libraries on Ubuntu, where the latest version of Boost in the Raspbian repositories is too old to make Bitmonerod.

You could try compiling Boost from source and installing it if you want to use Raspbian. Be warned it takes about 45-1hr to compile. If you do try this and get it to work please share the info as I couldn't get my rpi to find that I installed the new 1.55 boost. :/

hillbilly posted 8 years ago Replies: 2 | Weight: -310 | Link [ + ]

So it's bricking the internal sdhc cards? I'm confused as to why you're using an external..

Also, a pi2 with ubuntu and simplewallet would basically be an offline wallet, correct?

Reply to: hillbilly
wedgy2k posted 8 years ago Weight: -285 | Link [ - ]

I'll update the instructions to say SSD / USB - But yes I fried 3 SD Cards and killed one 32gb USB stick before NoodleDoodle's git hub commit of the specific Arm Build. Having your root partition on a USB makes it a lot quicker, having your root partition on an SSD makes it lightning. I may just migrate it now its working to USB so I can re-use my SSD for something else.

Reply to: hillbilly
saddam posted 8 years ago Weight: -307 | Link [ + ]

The daemon seems to be rough on SD cards. I got corruption on one after syncing for a few days, besides using an external HD is so much faster.

saddam edited 8 years ago Weight: -313 | Link [ + ]

I wish ubuntu would enable ssh by default! What a hassle connecting a monitor and keyboard just to get ssh going.


Thanks Wedgy2k!