Please login or register.

Experimental trezor firmware testing

DO NOT UPGRADE YOUR FIRMWARE IF YOU DON'T HAVE YOUR RECOVERY SEEDS

I worked on a trezor firmware which supports XMR awhile back but stopped development around August last year. I want to "complete" the firmware soon and then release the source to github when it's somewhat stable. I'm releasing the binary since I need help testing the current version.

While there are user interaction limitations, the firmware is fully functional and can be used to sync accounts as well as transfer XMR from active accounts. Only simplewallet is supported at the moment and from my testing, windows is fairly stable while linux needs some work [FIXED].

The firmware is compatible with BTC and does not remove any functionality available in the official firmware. The source is upstream compatible and can be merged to the official source (if they want to). XMR uses the same seed as BTC so you can restore your old seed anytime and regain your old account.

There are important points to note:

  • The viewkey is sent to the client. A bad client could potentially store these keys and see all incoming transactions to your account, privacy is then compromised.
  • The client has no access to the sendkey and can only request the device to generate key images or sign transactions. Your funds are safe.
  • It takes about 40ms to generate each key image. For large wallets, re-sync is going to take a while, so keep the wallet bin files.
  • [FIXED] The send confirmation prompt is incomplete. It will be fixed in subsequent versions.
  • [FIXED] There is no reconnect/retry implemented in simplewallet at the moment.
  • Max mix level is 9

V0925: trezor_xmr_test_firmware_0925

  • Updated to trezor source v1.4.0

V0313: trezor_xmr_test_firmware_0313_win64

V0313: trezor_xmr_test_firmware_0313_linux64

V0313: trezor_xmr_test_firmware_0313_osx64

  • Fixed Bus: 10 error

V0311

  • Added reconnect handler when trezor is unplugged while simplewallet is active
  • Added tx_seckey storage support to firmware
  • Added support for 'address' simplewallet command
  • Fixed support for entering passwords when trezor is initialized/recovered with password protection enabled

V0306

  • Added binaries for linux-64 and osx-64
  • Fixed usb transport bug in linux/osx
  • Updated source to master b96147030cf06b7adacafebff196bc23a4b19199
  • Added trezorctl to wipe, reset, recover the trezor
  • Added trezorctl option to recover the monero mnemonic from the trezor seed given a specific address index

V0303

  • Added send prompts when transferring xmr with multi destination support.
  • Fix: added error handler when mixin level is > 9
  • Fix: added error handler when sending to > 10 addresses in a single transaction.

V0301

  • Test release

Upgrade instructions:

  1. Disconnect the trezor from the USB cable.
  2. Press both buttons on the trezor then connect the USB cable.
  3. Run upload.bat. Wait until new firmware upload is completed.
  4. Verify firmware fingerprint (from fingerprint.txt)
  5. Disconnect then reconnect trezor to USB.
  6. Go to MyTrezor.com (using CHROME) and initialize your device. (You have the option to restore your SEED words if you want to keep using the trezor with your current BTC (etc.) account.
  7. Close CHROME. Otherwise, it will not release the trezor USB device and simplewallet will not find it.
  8. Run simplewallet.exe --hardware-wallet n (n can be any reasonable number eg. --hardware-wallet 0)

PIN Entering: https://github.com/trezor/python-trezor

47AYtJeNKJjYNZLj71nBW938mbFSFwq1x4qVcNhBmdfUjhaqiGN7wqpVjH419eLYPzHFeF3TgzY2fDivz5EyGBYUSbAXwed

Replies: 58
antanst posted 1 year ago Replies: 2 | Weight: 0 | Link [ - ]

After a few months of usage, this firmware works spectacularly well in combination with MyTrezor's BTC wallet. Satoshilabs has recently released a new firmware with some fixes to make Trezor more usable in parallel from multiple services. Is there a chance that you are going to rebase your changes on top of the newer firmware? Thank you for your hard work so far.

Reply to: antanst
throughnothing edited 1 year ago Weight: 0 | Link [ - ]

I'd like to second this. It would be great to see the firmware upgraded with the latest "mainline" Trezor improvements.

Additionally, as your firmware seems to be mostly working fine thus far, it would be great to begin to see this work open sourced. I'd like to use Trezor to more securely store larger amounts of XMR, but I wouldn't recommend anyone do that with closed software that others haven't been able to inspect. Do you have a timeline for source code release? I believe this will only help us get this to be even better faster/sooner, as others (myself included) are sure to jump in and help improve the firmware code.

Thanks again for all your hard work so far on this!

Reply to: antanst
throughnothing posted 1 year ago Weight: 0 | Link [ - ]

I'd also like to point out that I believe the Trezor devs (and Satoshi Labs team) would be open to getting this into the main firmware. You can see how well the discussion for ethereum support went here: https://github.com/trezor/trezor-common/pull/11

I'd love to see the code for this on github, so it can start being reviewed and begin the discussion for consideration in the main trezor firmware.

wedgy2k edited 1 year ago Weight: 0 | Link [ - ]

Brillaint NoodleDoodle - thank you

OSX 10.11.3 Trezor Clone - eWallet

Followed above instructions 1- 5

Accept non std firmaware and tick (this will come up a lot until final release)

initialise it on MyTrezor.com like as normal but set a password and write down 24 word seed!

to start with a remote node, my RPi2 :-D ,

./simplewallet --daemon-address 192.168.0.X:5012 --hardware-wallet 0

Enter password as set on MyTrezor website

Enter Pin as set on MyTrezor website

with Mini wireless keyboard, I cannot work out number positions so have plugged in an old clunky "shell key" MAC Keyboard #FAIL using the postions on the number pad (not the actual numbers...)_

refresh and wait / balance

Have successfully recieved 1 xmr on it

Have successfully sent 1 xmr from it

palexander posted 1 year ago Weight: 0 | Link [ - ]

Many thanks to NoodleDoodle for doing this. This makes using and storing XMR securely, a breeze.

NoodleDoodle edited 1 year ago Replies: 1 | Weight: 0 | Link [ - ]

V0311 now up. Please report bugs.

Reply to: NoodleDoodle
ferretinjapan posted 1 year ago Replies: 1 | Weight: 0 | Link [ - ]

Great stuff! Not so much a bug right now, but I'm not sure how to extract the seed using trezorctl, in the syntax you specify a word_list argument, what do I put here? Also, not 100% sure, but it may be that v0301's simplewallet address and v0311's simplewallet address are totally different, I double checked I entered the seed I originally generated using the v0301 firmware, but when that same 24 word seed is restored onto the new firmware and loaded with the new version of simple wallet, it returns a completely new public address. I tried to use the v0301 simplewallet to confirm, but it crashes with the new firmware saying it is missing a field.

Reply to: ferretinjapan NoodleDoodle
NoodleDoodle edited 1 year ago Replies: 1 | Weight: 0 | Link [ - ]
  1. The word_list argument is the 24 recovery seed (trezor) separated by space. e.g. trezorctl recover_mnemonic 0 "" English 1st_word 2nd_word 3rd_word etc...
  2. Unfortunately, the addresses changed when they were made to be monero mnemonic compatible. If there's some balance in the old wallet, you can only access them using V301/V303
Reply to: NoodleDoodle ferretinjapan NoodleDoodle
ferretinjapan posted 1 year ago Weight: 0 | Link [ - ]

Thanks for the clarification on the word list, I'd already moved all the Monero out of the old account so the address changing wasn't a problem.

antanst posted 1 year ago Weight: 0 | Link [ - ]

Just tried V0311, on a pristine (BTC-only) Trezor. Tried flashing via the Chrome app, wallet open/close, refresh & sync, transfer and disconnect/reconnect the Trezor while in simplewallet.

Everything worked amazingly well. Thank you! (donated)

A humble suggestion: Please note in the instructions your suggestion to use the numeric keypad when entering the PIN. It's somewhat confusing for a first-timer.

antanst posted 1 year ago Weight: 0 | Link [ - ]

After a couple of transactions, the wallet is crashing. I consistently get a Bus error: 10 message right after opening the wallet, and simplewallet exits. Tell me if you need any more information on this.

antanst posted 1 year ago Weight: 0 | Link [ - ]

I just noticed you fixed the bug before I could even respond. I can confirm it works fine. Thanks!

wedgy2k posted 1 year ago Weight: 0 | Link [ - ]

Installed V0313 OSX (eWallet). Frimware upgrade following 1-5 as above. 6 restored seed and password on mytrezor website that i set up for V0306. Works fine and same wallet (address) inc small balance, restored ok.

pa edited 1 year ago Weight: 0 | Link [ - ]

Tested V0313 using Trezor and OS X 10.11.3. Everything worked well, including sending and receiving in simplewallet. (The only problem I had was failed firmware upgrade due to USB cable failure. Swapping cable fixed that.)

Impressive work, @NoodleDoodle!

pa posted 1 year ago Weight: 0 | Link [ - ]

It would be wonderful if NoodleDoodle's work could be integrated with the upcoming official GUI! In particular, Trezor PIN entry via GUI would be very helpful.

xmrdc posted 1 year ago Weight: 0 | Link [ - ]

Tested build 313 on OSX v. 10.9.4. Was able to send and receive .2xmr just fine. Can also log into mytrezor.com

pa posted 1 year ago Replies: 1 | Weight: 0 | Link [ - ]

NoodleDoodle, How secure is the Trezor code at this point? Is it ready to entrust with medium or large amounts of XMR?

Reply to: pa
dEBRUYNE posted 1 year ago Replies: 1 | Weight: 0 | Link [ - ]

I'd wait until the code is released on Github and merged upstream by Trezor (and thus signed).

Reply to: dEBRUYNE pa
NUKE1989 posted 1 year ago Weight: 0 | Link [ - ]

Any subjective guess about how much time this will take? After the reddit post about mymonero (which might be just fud anyway) i would prefer to send what amounts i keep there to trezor.

tatt88 edited 4 months ago Replies: 1 | Weight: 0 | Link [ - ]

It seems like the github repo is gone now. Has it been relocated somewhere? Also version 0925 link is dead.

Reply to: tatt88
skaht posted 10 months ago Replies: 1 | Weight: 0 | Link [ - ]

See https://www.reddit.com/r/TREZOR/comments/5ezhly/monero_with_trezor/. Would not surprise me if the V0925 link is dead.

Reply to: skaht tatt88
tatt88 posted 10 months ago Weight: 0 | Link [ - ]

Thank you, I was able to find the code via the reddit threads. Much appreciated. Too bad to see that the project appears dead for the time being :/